Dtdb deckbuilder is beautiful

feeling pretty dumb right now because i cant figure out how to use dtdb deckbuilder to search on a cards text/keywords (assuming huckster et al is a keyword). even using the syntax filters that they suggest (k: …) my searches only seem to be searching on card titles. is it buggy or am i just a retard? what am i doing wrong?

Just tried it k:huckster worked for me. No space.

ok i got it, their tooltip is incorrect for dumbass noobs like me. the tooltip suggests i was supposed to put in “k: huckster” which returns nothing (as opposed to “k:huckster” which works).

No prob I was just on playing around on there just seen the question ping so I tried it out.

You’re referring to this tooltip right?

t:dude k:abomination

I don’t see any spaces here.

Then, there is the Search page where you can select any keywords from a drop-down menu.

So, what is incorrect or confusing about dtdb?

The tooltip does appear to have a space in it (at least on chrome).

You cannot tell me there is no space shown there because I have eyes :slight_smile:

I’m using Chrome and I just quoted from that page, there are no spaces. Here’s a screenshot.

I wouldn’t press the issue normally but the topic name is really loud.


It needs to be loud so they can fix their tooltip :wink:

Perhaps it is because I am on windows 10 because I also find the clicked vs unclicked of the filter buttons to be nearly indistinguishable from one another.

This is the list of letters used as search criteria, i.e. explanation of keys, not examples. Here “k: keyword” means that “k” is used to search for keywords. Examples are provided below, under “Search examples”.

The screenshot you provided shows that you are using a phone, which is not mentioned in your opening post. This page looks different on a computer (“k - keyword” rather than “k: keyword”, so there is no way to confuse it with a search example).

They can only fix a problem if you explain clearly what the problem is. From what you wrote in the opening post, it is difficult to reproduce what you’re experiencing.

Would you provide a screenshot of what clicked vs unclicked buttons look like under Windows 10?

The page literally looks identical on my desktop as it does on my phone (iPhone 6+). I’ll grab a screen of the click vs unclicked in the morning (it’s 3am here and I’m already in bed :P).

But to say “there is literally no way to confuse it” in a thread that only exists because someone confused it…a little short sighted. Just because it is clear to YOU does not make it clear to all.

I said there is no way to confuse “k - keyword” with “k:keyword”.
You are seeing a colon (:slight_smile: instead of a dash (-).

Here’s what this page looks like on both my computer and my phone:

You are seeing this page differently. Or maybe its another page altogether.
How did you get to that tooltip? What did you press to open it?

In the beginning i got confused by “k: keyword”, too. Figured it out with a bit of trying around (never managed more than 1 criteria at once though).

Thanks for pointing to the Search syntax thingy, never noticed that one, rtfm i guess xD

Where did you see “k: keyword”? I cannot figure out where that page is on the website.

When you go into Edit a Deck, then press the Filter help button (Firefox in Windows 7)

Oh! That helps, thanks!

Ok, I submitted the issue.

1 Like

Not the most straightforward of interfaces but here’s how you do multiple criteria.

AND comparison (return cards with the keywords Huckster AND Harrowed)
k:Huckster k:Harrowed

OR comparison (return cards with the keyword Huckster OR Harrowed)

You can also be a little smarter with the Skill based keywords, so to return all Huckster 1s, you search for
k:“Huckster 1”

and similarly to the above search
k:“Huckster 1”|Harrowed
k:“Huckster 1” k:Harrowed

Note the quotation marks are only around the Huckster 1, since this is the keyword you’re searching for. If you wanted to search for Huckster 1 OR Huckster 2, the search would be
k:“Huckster 1”|“Huckster 2”

In case it wasn’t obvious, you can also combine ORs and ANDs to get even funkier searches.

So to search for something with is either a (Weapon OR Gadget) AND Experimental.
k:Weapon|Gadget k:Experimental

EDIT So I was playing around some more and there’s also a NOT comparison. Again, the interface is entirely unclear but here’s how you do it.

NOT Huckster
k!Huckster (note, there’s no colon, just an exclamation mark)

NOT (Huckster OR Harrowed)

Huckster AND NOT “Huckster 1”
k:Huckster k!“Huckster 1”

Huckster AND NOT (“Huckster 1” OR Harrowed)
k:Huckster k!“Huckster 1”|Harrowed

A limitation seems to be you can’t do (NOT A) OR B. It’s still early so there’s probably some alternative logic to define the search you actually want that involves ANDs.

Lastly, in case it’s not obvious, you can combine ANDs with different searches
Huckster AND value 10
k:Huckster v:10

Huckster AND NOT value 10
k:Huckster v!10

Hope that helps!


This is perfect!
So, i only tried the AND clause, didn’t realize and never inquired further after that, makes sense, thanks!! :slight_smile:

I can see how doomtown rules or card templates, some dt arts, local moderate policy or octgn module(for newbies) are confusing. But dtdb is the only thing about doomtown that is perfect.

All hail Aliscende and Platipus!